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CellarTracker! Crestron Module 
(version 1.0) 

 
 
System Requirements 
 
Hardware Requirements 
The CellarTracker Crestron module requires the following hardware/software/firmware components: 
 

! Ethernet Router with Internet access 
! Crestron 2-series control processor with Ethernet (except AES/AADS/AMS) 
! Crestron touchpanel with minimum resolution of 640x480 
! Crestron touchpanel with Ethernet support (for Dynamic Graphics support) 
! SIMPL Windows® 2.10.32 or later 
! SIMPL+ 3.03.08 or later 
! Crestron Database 20.00.015.00 or later 
! Device Database 20.02.009.00 or later 
! Processor firmware 4.000.0226 or later (for processor hosting CellarTracker module) 

 
 
 
 
 
Crestron Software Components 
The CellarTracker Crestron module includes the following software components: 
 

! CellarTracker-v1.zip  (contains the Crestron module set and this help file) 
! CellarTracker-Dedicated.zip (contains a pre-configured SIMPL Windows program and RSD) 
! CellarTracker-1024.vtt  (VisionTools template for 1024x768 resolution touchpanels) 
! CellarTracker-800.vtt  (VisionTools template for 800x600 resolution touchpanels) 
! CellarTracker-640.vtt  (VisionTools template for 640x480 resolution touchpanels) 
! CellarTracker-Demo.zip  (contains demo smw, spz and Xpanel-exe elements for demo purposes) 

 
 
 
 
 
CellarTracker! Activation 
CellarTracker! is a subscription-based online service which requires account registration.  The use of 
this module in a Crestron solution requires activation with CellarTracker!  To activate the module, you 
must contact CellarTracker! with a valid account id and request they turn on Crestron services for the 
account.  Appropriate activation charges will be applied at this time.   Once activated, the module is 
authorized to transmit data with the registered CellarTracker! account.  
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Hardware Setup 
 
Processor Data Storage Setup 
!"#$%#&&'(!(')*#($+,-.&#$./#/$/,0#$12&#/$3,$/3,(#$-'3'$4##-#-$1,($235/$,6#('32,47$!"#(#$'(#$8$6&')#/$,4$
the processor that can be used to store these files; Compact Flash card and NVRAM. 
 
If you have a CF card installed on your processor 

You are done! There is no special setup needed to support CompactFlash. 
9206&:$/#&#)3$3"#$,632,4$;%ompactFlash<$1(,0$3"#$FileStorage parameter on the module. 

 
If you DO NOT have a CF card installed in your processor 

If you are not using a PAC2/PRO2/AV2/PAC2M/DIN-AP2 processor, or do not have a CF card 
installed in your processor, you will need to setup an NVRAM disk if you have not already done so: 
 
1) Connect t,$3"#$6(,)#//,($./24=$!,,&>,?5/$!#?3$%,4/,&#$3,,& 
2) Type NVRAMDISK<enter> 
3) If the processor comes back with NVRAMDISK: 128K :,.$'(#$-,4#@$A3"#(B2/#C 
4) Type NVRAMDISK 128k<enter> 
5) Type Y<enter> when prompted 
6) Type NVRAMDISK<enter> to confirm the command took. The processor should reply with 

NVRAMDISK: 128K. If not, go back to step 4 and try again. 
 
** You may substitute 64K for 128K in the above examples if this is more appropriate to your installation 
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Processor/Touchpanel Ethernet Setup 
Use of the CellarTrack#($0,-.&#$(#D.2(#/$6(,6#($/#3.6$,1$3"#$6(,)#//,(5/$E3"#(4#3$/#3324=/$24$,(-#($3,$
access the internet properly. If you have already setup the processor for proper Ethernet and DNS 
operation, then you are ready, otherwise the rest of this section can help you setup this portion of the 
processor. 
 
These instructions will assume that you have 3 important pieces of information already: a static IP 
address to use for the processor, the subnet mask of the network and the IP address of the default router 
for internet access on the network.  If you do not have this information, please contact the network 
administrator or homeowner to acquire this information. 
 
If the network is a private network in a residence, and no IT administrator is responsible for it, a static IP 
address can be calculated based on 2 pieces of information: the IP addressing scheme and the DHCP 
range of the network.  F,3"$,1$3"#/#$)'4$>#$,>3'24#-$1(,0$3"#$-#1'.&3$(,.3#(5/$GHI$),412=.('32,4$
screens.  The addressing scheme will be the first 3 numbers you enter to navigate to the setup of the 
router (e.g. if you navigate to http://192.168.1.1 to access the router, then the addressing scheme is 
192.168.1.x). From that setup you should also be able to locate the DHCP range.  The subnet mask will 
also be shown here, so please write this down and -,453$1,(=#3$237$ 
 
To choose an address for your processor, simply use the first 3 numbers from the IP addressing scheme, 
then choose an unused number for the last digit that is between 1 and 254.  Make certain to not use any 
numbers within the DHCP range, nor the same number as the router.  Once selected, you can run a test 
to make sure the chosen address is not in use. G#35/$3(:$'4$#?'06&#$B"#(#$:,.$"'J# a router whose 
address is 192.168.1.1 and the DHCP range is 100 to 150, and you choose 192.168.1.222 as an address: 

1) From your PC go to Start>Run and type cmd<enter> to bring up a DOS window: 
2) Inside the DOS window, type ping 192.168.1.222<enter>: 
3) The replies should come back slowly and with a Request Timed Out message repeating.  This 

means that the .122 address is available for use.  If you receive Reply from 192.168.1.122 
messages, then the .122 address is currently in use and you must choose a different IP address. 

 
Now we can setup the processor with the appropriate Ethernet configuration (using IP Address 
192.168.1.222, Subnet Mask 255.255.255.0 and Default Router of 192.168.1.1): 

1) %,44#)3$3,$3"#$6(,)#//,($./24=$!,,&>,?5/$!#?3$%,4/,&#$3,,& 
2) Type DHCP off<enter> 
3) Type IPA 0 192.168.1.222<enter> or IPA 192.168.1.222<enter> depending on processor type 
4) Type IPM 0 255.255.255.0<enter> or IPM 255.255.255.0<enter> depending on processor type 
5) Type DEFR 192.168.1.1<enter> 
6) Type ADDD 192.168.1.1<enter> (the address of the default router) 
7) Now everything is setup, just type EST<enter> and confirm that the HDCP, IP Address, Subnet 

Mask, Default Router and DNS 1 took. If not, go back and enter a command again. 
8) Reboot the processor 

 
**This same scenario/process applies to Ethernet enabled touchpanels as well if the bottle label support 
is desired.  K#1#($3,$3"#$3,.)"6'4#&5/$(#1#(#4)#$=.2-#$1,($#?')3$E3"#(4#3$),4/,&#$),00'4-$1,(0'3324=7 

http://192.168.1.1
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Software Setup 
 
SIMPL Windows® Conventional Installation 
The CellarTracker Crestron module is very easy to integrate into any SIMPL Windows program. 
However, please keep in mind the memory and resource load this module may put on your system and 
design hardware and code accordingly. This module uses default joins of: 

Digital = 1001 - 1198 
Analog = 101 - 129 
Serial = 100 - 218 

 
1) Add the Module 

a. Unzip the contents of the CellarTracker-v1.zip archive into either your project directory 
or your SIMPL Windows UserModule and UserPlus directories (this pdf and the .umc 
file go in UserModule, the .usp and .ush files go in UserPlus) 

b. Open your project (or if the project is already open, go to Project>Re-Synch Program). 
c. From the Symbol Library view, drag in the CellarTracker-v1 module. 
d. In the program view, make sure you have a touchpanel or Xpanel visible in the Ethernet 

or Cresnet slot trees, then right-click-drag the added CellarTracker module onto the 
panel. 9#&#)3$3"#$,632,4$;Import User Interface Connection logic<$1(,0$3"#$),43#?3$
menu. If desired, give the module5s signals a prefix (such as CellTracker_). Do not offset 
the joins! This will void any support available for this product. 

e. Be sure to set the PermanentStringSize on panels with such a parameter to 254d. 
f. You may repeat steps D & E for additional panels, just be sure to specify NO signal 

prefix this time. 
2) Set the parameters 

a. There is no need to tie the serial outputs of the module to an MSP 
(MakeStringPermanent) symbol, as they are already connected to one inside the module. 

b. If desired, define a default CellarTracker.com username and password in the appropriate 
parameters. 

c. Define the storage location for module data (as defined in Hardware section above) in the 
FileStorage parameter. 

d. !:6#$24$3"#$)&2#435/$4'0#$'/$:,.$B,.&-$&2*#$23$3,$'66#'($,4$3"#$3,.)"6'4#&$,4$3"#$
CellarTracker main page in the Client_Name parameter. 

3) Finished! 
a. The module is now ready to use. Compile and load. 
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SIMPL Windows® Dedicated Processor Deployment 
In the case where it is desired to deploy this module on a separate processor and then export/import the 
control and data signals to another processor in your system, we have provided a pre-assembled program 
for a QM-RMC to support this task. This method is desirable for several reasons, including speed and 
memory management. 
 

1) Preparation 
a. Unzip the contents of the CellarTracker-Dedicated.zip archive into your project directory. 
b. Open your project (or if the project is already open, go to Project>Re-Synch Program). 
c. Open the CellarTracker-Dedicated.smw program in a new instance of SIMPL Windows. 

2) Create the Link between the 2 programs 
a. In your project, import the CellarTracker-Dedicated.rsd file. Set the IP address of the 

imported EISC symbol at IPID-FE to the IP Address you will use for the dedicated 
processor. 

b. Copy the CellarTracker-v1 module from the CellarTracker-Dedicated program and paste 
into your program (anywhere, as this will be deleted later). 

c. In the program view or your program, make sure you have a touchpanel or Xpanel visible 
in the Ethernet or Cresnet slot trees, then right-click-drag the added CellarTracker 
module onto the panel. 9#&#)3$3"#$,632,4$;Import User Interface Connection logic<$
from the context menu. Do not give the module5/$/2=4'&/$'$6(#12?L$3"#:$"'J#$'$-#1'.&3$
prefix of CT to match the RSD. Do not offset the joins! This will void any support 
available for this product. 

d. Be sure to set the PermanentStringSize on panels with such a parameter to 254d. 
e. You may repeat steps C & D for additional panels, remembering to specify NO signal 

prefix. 
3) Finalize the Link in your program 

a. H--$'4$+9M$/:0>,&$3,$:,.($6(,=('0N$/#3$235/$PermanentStringSize to 254d, and drag all 
of the serial signals from the EISC at IPID-FE to the MSP. 

b. Delete the CellarTracker module from your program that we added in step 2-B. 
4) Finalize the Dedicated program 

a. In the CellarTracker-Dedicated program, set the IP address on the EISC symbol at IPID-
FE to the IP address of the processor hosting your program. 

b. If desired, define a default CellarTracker.com username and password in the appropriate 
parameters. 

c. !:6#$24$3"#$)&2#435/$4'0#$'/$:,.$B,.&-$&2*#$23$3,$'66#'($,4$3"#$3,.)"6'4#&$,4$3"#$
CellarTracker main page in the Client_Name parameter. 

d. Convert the QM-RMC to whatever processor type you will be using to host this program 
and save. 

e. Define the storage location for module data (as defined in Hardware section above) in the 
FileStorage parameter. If using a QM-RMC, leave it at NVRAM. 

5) Finished!  
a. Save, compile and upload both programs. 
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VisionTools Pro-e® 
The CellarTracker module VisionTools support files are ready to be added into any project easily. 
+,-212)'32,4$,1$'4:$,1$3"#$%#&&'(!(')*#($#&#0#43/5$O,24$4.0>#(/$B2&&$J,2-$'4:$/.pport available for this 
product. 
 

1) Open the CellarTracker VisionTools$3#06&'3#$3"'3$0'3)"#/$:,.($#?2/324=$3,.)"6'4#&5/$(#/,&.32,4$
(i.e. 800 for 800x600 panels such as TPS-12, TPMC-8x, etc.) 

2) Open your existing project. Right click on either project in the Project View and make sure that 
Show Folders is selected. 

3) Now, just drag the CellarTracker folder from the template to your project. 
4) Create a page flip from your existing panel layout to the CellarTracker! Page. 
5) If bottle label support is not needed or possible and you so desire, delete the large button with the 

Crestron logo at the top right of subpages CellarTracker P Detail and CellarTracker P Detail-List 
and the label below that button. 

6) Finished! Save, compile and upload your touchpanel project. 
 
Repeat this same procedure for all other panels in your project. 
 
 
 
 
 
 
 
 
Custom Integration Options 
For those not faint of heart, the integration of the CellarTracker! module can be customized for systems 
that require it. This procedure will assume you have an extensive knowledge of Crestron software 
programming. However, any deviation from the predefined join number scheme will void any support 
available for this product. 
 
In SIMPL Windows, for those requiring new join number ranges (due to existing join number usage in 
6(,O#)3N$#3)7QN$:,.$0':$;,11/#3<$3"#$O,24/$./#-$24$3"#$;206,(3<$6(,)#//7$M&#'/#$*##6$3(')*$,1$3"#$O,24$
offsets used for digital, analog and serial joins at this step, as you will need to use the same offsets 
during the VT import process. 
 
If using the Dedicated program for CellarTracker function export, and needing to export to multiple 
processors, simply copy the exiting EISC symbol to additional symbols and create RSD files for each to 
be exported to other processors. Follow the procedure for integrating into your program as outlined 
above for each processor. 
 
In VisionTools, instead of  dragging the CellarTracker folder to your project, first create a CellarTracker 
folder in your project. Then copy the CellarTracker folder from the template projec37$G'/3&:N$;6'/3#$
/6#)2'&<$243,$3"#$%#&&'(!(')*#($1,&-#($,1$:,.($6(,O#)3$'4-$246.3$3"#$,11/#3$O,24/$./#-$'>,J#$24$9R+MG$
Windows. 
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Using the Demo Program 
The included Demo program can be used for demonstration purposes in your showroom. This demo is 
ready to deploy by just loading into a properly set up QM-RMC. The included Xpanel-exe5/ can be used 
to demonstrate the power of CellarTracker!. S"#4$./24=$3"#$24)&.-#-$T#0,$#?#5/N$>#$/.(#$3,$3:6#$24$3"#$
IP address of your control processor under the Options>Settings menu item of the Xpanel-exe. Or you 
may save any of the included VTT templates as a touchpanel and run a dedicated demo from a 
touchpanel. Touchpanels connect to the demo program via IP-IDs 03 and 04 (two panels are supported 
in the demo). Alternatively, you may integrate the CellarTracker! module and graphics into your 
existing showroom program by following the instructions above. The login information for the demo 
user can be found on the parameters of the module included in the Demo program.  
 


